CrossWorld FAQ

CrossWorld is currently for iOS 4.3 and above. Look forward to a more extensive iPad version with longer words!

If you are in need of any support for CrossWorld, please feel free to use our contact form.

 

Leave a Reply

Your email address will not be published. Required fields are marked *